2016年天梯赛初赛题集 7-1 到底有多二 (15分)


7-1 到底有多二 (15分)

一个整数“犯二的程度”定义为该数字中包含2的个数与其位数的比值。如果这个数是负数,则程度增加0.5倍;如果还是个偶数,则再增加1倍。例如数字-13142223336是个11位数,其中有3个2,并且是负数,也是偶数,则它的犯二程度计算为:3/11×1.5×2×100%,约为81.82%。本题就请你计算一个给定整数到底有多二。

输入格式:
输入第一行给出一个不超过50位的整数N。

输出格式:
在一行中输出N犯二的程度,保留小数点后两位。

输入样例:
-13142223336
输出样例:
81.82%

#include <iostream>
#include <cstdlib>
#include<string>
#include<cstdio>
using namespace std;
int main() {
    string s;
    double bs1=1;
    double bs2=1;
    int weishu=1;
    int ershu=0;
    int fu=0;
    double count=0;
    cin>>s;
    int i=0,j=0;
    if(s[0]=='-')
    {
        i++;
        bs1=bs1+0.5;
        fu++;
    }
    weishu=s.length()-fu;
    for(;s[i]!='\0';i++)
    {
        if(s[i]=='2')
        ershu++;
    }
    if((s[s.length()-1]-'0')%2==0)
    bs2=bs2+1;
    double al=(ershu*1.0/weishu)*bs1*bs2*100;
    cout<<ershu<<" "<<weishu<<' '<<bs1<<' '<<bs2<<endl;
    printf("%.2lf",al);
    cout<<"%"<<endl;

    
    system("pause");
    return 0;
}

文章作者: LHL
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 LHL !
评论
  目录